Ru-Board.club
← Вернуться в раздел «Microsoft Windows»

» Установка Win4Lin в Mandrake 10

Автор: Xpensus
Дата сообщения: 23.09.2004 16:20
Кому удалось в 10-м Mandrake поставить Win4Lin? Помогите! Пытался устанавливать w4l 5.2.2 workstation, ядро 2.6.4 с кернел.орг пропатчил по инструкции с нетраверс.ком, скомпилировал модули и ядро, установил, загрузился, а модули Win4Lin загружаться не хотят Загружающий скрипт говорит, что не находит /proc/ksyms. Я выяснил, что в 2.6.х ядрах этот файл называется /proc/kallsyms. И как Win4Lin объяснить разницу???? mki_adapter загружается нормально.
Автор: eugrus
Дата сообщения: 24.09.2004 16:18

Цитата:
что не находит /proc/ksyms. Я выяснил, что в 2.6.х ядрах этот файл называется /proc/kallsyms. И как Win4Lin объяснить разницу????

очень просто

сделать

ln /proc/kallsyms /proc/ksyms
Автор: Demetrio
Дата сообщения: 24.09.2004 16:20

Цитата:
ln /proc/kallsyms /proc/ksyms

В файловой системе proc делают симлинки???
Автор: eugrus
Дата сообщения: 24.09.2004 16:24
ой
ой
ой

оплошал...
Автор: Demetrio
Дата сообщения: 24.09.2004 16:25

Цитата:
The Linux kernel makes a special filesystem available, which is mounted under /proc on Linux systems. This is a "pseudo-filesystem'' because it doesn't really exist on any of your physical devices.


eugrus
Почитай для самообразования
http://www.redhat.com/docs/manuals/linux/RHL-9-Manual/ref-guide/ch-proc.html
Автор: eugrus
Дата сообщения: 24.09.2004 16:48
да...
знаю...
вспомнил...
извините...

стыжусь...
Автор: Drron
Дата сообщения: 24.09.2004 17:45
А ты взял тот патч что нужно? Тебе нужен mki-adapter26_1_3_7.patch.

Смотри https://www.netraverse.com/member/downloads/kernel_patch.php
Автор: Xpensus
Дата сообщения: 29.09.2004 15:49
2 Drron
Да именно этот патч я и использовал. Ядро патчится и собирается на ура. А вот инсталлер win4lin упорно заявляет о том, что в ядре не включена поддержка. Установка вручную заканчивается тем же - невозможно загрузить драйвера win4lin.
Автор: Drron
Дата сообщения: 29.09.2004 18:22
У меня такое же было, но я грешил на то что скачал не тот дистрибутив. Вылечилось заменой ядра на 2.4.22 и установкой mki-adapter.patch.
Автор: kullibbin
Дата сообщения: 27.11.2004 12:09
Люди добрые, неужели никто так и не поставил его на 2.6 ядро? Очень нужно, но не получается ничего. Та же причина - говорит, что ядро не патченное, хотя оно патченное. Помогите!! На 2.4 ядро - не устраивает, там под мое железо дров нет.
Автор: Demetrio
Дата сообщения: 27.11.2004 12:15
ftp://ftp.aso.ee/pub/Mandrake/official/10.1/i586/media/contrib/kernel-win4lin-2.6.8.1.12mdk-3-11mdk.i586.rpm
ftp://ftp.aso.ee/pub/Mandrake/official/10.1/i586/media/contrib/kernel-multimedia-win4lin-2.6.7-1.mm.7mdk-1-1mdk.i586.rpm
ftp://ftp.aso.ee/pub/Mandrake/official/10.1/i586/media/contrib/kernel-tmb-win4lin-2.6.7-2.tmb.6mdk-1-1mdk.i586.rpm

на одно из этих не ставится?
Автор: kullibbin
Дата сообщения: 27.11.2004 18:24
На первые два не ставится точно. Пробовал патчить сам - тоже не ставится. Кто поставил, запостите, плиз, точную версию самой win4lin и ядра. Еще и кей можно
Автор: kullibbin
Дата сообщения: 29.11.2004 09:54
Вот, при установке через консоль получаю такое сообщение:

License not fully activated because unable to unload modules.
This is probably because the product is currently in use.
Inspect the log file /var/win4lin/log/activate_license.log
for details.

Содержимое указанного лога:

Пнд Ноя 29 10:47:17 MSK 2004
Log of activate_license
Running unloadem
unloadem retval 1

Чего ему надо?

Страницы: 1

Предыдущая тема: TV tuner & Windows2000 Проблема в ShutDown


Форум Ru-Board.club — поднят 15-09-2016 числа. Цель - сохранить наследие старого Ru-Board, истории становления российского интернета. Сделано для людей.