Ru-Board.club
← Вернуться в раздел «В помощь системному администратору»

» Доступ из вне к локалке

Автор: Kyrgyz_Admin
Дата сообщения: 02.09.2009 11:49
Доброго всем времени суток Господа !!!
Сетуация такая, имеется киска 2811 и ISP. Киску уже настроил чтоб он раздавал инет. А мне нужно чтобы с инета по определенному порту стучались на мой вн. сервер.
вот и конфиг

interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address XXX.XXX.XXX.XXX 255.255.255.248
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 XXX.XXX.XXX.XXX
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/1 overload
ip nat inside source static tcp 192.168.1.52 9999 XXX.XXX.XXX.XXX 9999 extendable
!
ip access-list extended PERMIT
permit ip host 192.168.1.10 any
permit ip host 192.168.1.51 any
deny ip any any
!
access-list 1 permit 192.168.1.0 0.0.0.255
Автор: Valery12
Дата сообщения: 02.09.2009 12:31
а это что

Цитата:
ip nat inside source static tcp 192.168.1.52 9999 XXX.XXX.XXX.XXX 9999 extendable

разве не проброс 9999 порта на 192.168.1.52
Автор: Kyrgyz_Admin
Дата сообщения: 02.09.2009 13:04
проброс порта, все правильно, но никак не могу попасть на вн комп
Автор: vlary
Дата сообщения: 02.09.2009 14:22
Раз уж имеется киска, то совсем не трудно организовать полноценную VPN (IPSec или SSL, по желанию).
И тогда уже ничего не нужно пробрасывать. После установки соединения на клиенте будет
полный доступ ко всем ресурсам внутренней сети. В случае IPSec на клиентском компе нужен Cisco VPN Client,
в случае SSL вообще ничего не нужно, соединение устанавливается через Интернет Эксплорер.
Автор: Valery12
Дата сообщения: 02.09.2009 14:26
на interface FastEthernet0/1 никаких access-list не прикручено?
на 192.168.1.52 шлюз по умолчанию 192.168.1.1?
что за приложение работает на порту 9999?
используется только один порт? и действительно это TCP а не UDP?
Автор: Kyrgyz_Admin
Дата сообщения: 02.09.2009 14:44
мне не нужно ничего организовывать, так ак по определенному порту только даю доступ к своей БД, и я уверен что это TCP
Автор: Valery12
Дата сообщения: 02.09.2009 14:54
я бы все таки посмотрел настройки сети на 192.168.1.52, во первых шлюз, во вторых нет ли там виндового фаервола (или какого другого) ведь при маппинге запросы идут с реальных IP, ну и настройки базы данных, нет ли там каких ограничений
Автор: Kyrgyz_Admin
Дата сообщения: 03.09.2009 06:16
все, заработал, спасибо Вам товарищи, дело было в шлюзе, а теперь другая проблема, когда я с инета пытаюсь зайти Radminom на 192,168,1,52 меня сразу же выкидивает, хотя телнетом туда я безпроблем попадаю, на 1,52 файервол отключен, антивир стоит Касперский, в чем может быть трабла???
Автор: Valery12
Дата сообщения: 03.09.2009 06:59
на сколько я знаю порт Radmin    - TCP 4899, принцип маппирования тот же,
но вот по такому доступу как telnet и Radmin я полностью согласен с vlary нельзя пробрасывать такие порты, нужно организовать cisco easy vpn server
Автор: Kyrgyz_Admin
Дата сообщения: 03.09.2009 08:15
спасибо, наверное действительно начну организацию cisco easy vpn server

Страницы: 1

Предыдущая тема: Профессиональные тесты для системных администраторов.


Форум Ru-Board.club — поднят 15-09-2016 числа. Цель - сохранить наследие старого Ru-Board, истории становления российского интернета. Сделано для людей.