Ru-Board.club
← Вернуться в раздел «В помощь системному администратору»

» Помогите с gns3 пожалуй

Автор: t3hn01d
Дата сообщения: 25.04.2010 05:23
Мучаюсь уже второй день с gns 3
Есть комп с двумя сетевухами
1. сетевуха с доступом в инет 172.19.0.148 маска 255.255.255.224 (шлюз 172.19.0.130 реальная циска 2811)
Доступ к инету через внешний прокси 172.16.3.9

2. сетевуха 192.168.5.2 маска 255.255.255.0 подключена к свечу (обычная мыльница)

есть задача, дать доступ к прокси серверу 172.16.3.9 подсети 192.168.5.0
уже столько примеров опробовал не чего не получается.
Создал в gns3 маршрутизатор и два облака привязанных к реальным сетевухам, пинги не проходят не то чтобы увидеть прокси сервер, я в этом деле новичок, подскажите что в конфиге не так?


version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
!
ip audit po max-events 100
!
interface FastEthernet0/0
ip address 172.19.0.146 255.255.255.224
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
ip nat pool pool1 172.19.0.1 172.19.0.223 netmask 255.255.255.0
ip nat inside source list 1 pool pool1 overload
ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 172.19.0.130
ip route 192.168.5.1 255.255.255.255 172.19.0.130
!
!
access-list 1 permit 191.168.5.0 0.0.0.255
!
line con 0
line aux 0
line vty 0 4
!
!
end
Автор: vlary
Дата сообщения: 25.04.2010 08:27

Цитата:
ip route 192.168.5.1 255.255.255.255 172.19.0.130
Это что за чушь?
Автор: t3hn01d
Дата сообщения: 25.04.2010 08:34
вот поправил, но не чего не выходит не вижу из сети 192.168.5.0 адрес прокси сервера
вот новый конфиг....

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
!
ip audit po max-events 100
!
ip nat pool net-155 172.19.0.155 172.19.0.165 netmask 255.255.255.224
ip nat inside source list 1 pool net-155
!
!
interface FastEthernet0/0
ip address 172.19.0.156 255.255.255.224
ip nat outside
serial restart-delay 0
!
interface FastEthernet1/0
ip address 192.168.5.1 255.255.255.0
ip nat inside
duplex auto
speed auto
access-list 1 permit 192.168.5.0 0.0.0.255
!
ip route 0.0.0.0 0.0.0.255 172.19.0.130
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
Автор: vlary
Дата сообщения: 25.04.2010 10:20

Цитата:
Есть комп с двумя сетевухами

Цитата:
есть задача, дать доступ к прокси серверу 172.16.3.9 подсети 192.168.5.0
А причем здесь тогда коип? На модеме есть интерфейс 192.168.5.0, он и будет шлюзом. Как я понял, это конфиг модема? С самого модема пинги на шлюз, прокси, и в интернет идут?

Автор: t3hn01d
Дата сообщения: 25.04.2010 10:43
Это не модем, это эмулятор циски, с самой циски пинги идут, думаю проблема с роутингом
Автор: vlary
Дата сообщения: 25.04.2010 11:15

Цитата:
с самой циски пинги идут
А с эмулятора и на эмулятор пинги идут? С циски на эмулятор, с клиентов сети 192.168.5. на эмулятор?
Автор: t3hn01d
Дата сообщения: 25.04.2010 11:33
да идут пинги, мне нужно правильно построить маршрут чтоб пинши пошли от прокси сервера
Автор: vlary
Дата сообщения: 25.04.2010 15:33
Возможно, прокси-сервер принимает пакеты только от вашей циски, а остальные игнорирует. Тогда нужно поднимать НАТ на циске, а не эмуляторе.
Автор: t3hn01d
Дата сообщения: 26.04.2010 09:34
спасибо за внимание и советы, разобрался настроил, могу кинуть рабочий конфиг, все дело было в access листах и маршрут надо было прописать до прокси сервера.
Автор: sfunlimit
Дата сообщения: 21.07.2011 10:24
Всем привет.
Я в этом деле новичок так что прошу ногами не пинать =)
Скачал GNS3 (all in one) с оф сайта.
На нашем форуме скачал образы.
Установил.
Далее выставил два маршрутизатора 3640. В слотах порты NM-1fe-tx
Соединил между собой - fast ethernet
Настроил адреса

192.168.0.1 255.255.255.0 и 0.2

R2>en
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#int fa 0/0
R2(config-if)#ip addres
R2(config-if)#ip address 192.168.0.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
*Mar 1 00:02:16.583: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:02:17.599: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to upe
R2(config)#exit
R2#
*Mar 1 00:02:25.087: %SYS-5-CONFIG_I: Configured from console by console
R2#wr
Building configuration...
[OK]
R2#


Пинги не ходят

что я не так делаю?

Изначально хотел подключить к реальной сети. Не вышло...
Потом когда начал проверять вышло что у меня даже маршрутизаторы друг друга не видят.
Команд не знаю, смотрю по ходу разбираюсь.
Автор: urodliv
Дата сообщения: 21.07.2011 10:34
sfunlimit
Интерфейсы подняли?
Автор: sfunlimit
Дата сообщения: 21.07.2011 10:36
urodliv
а как? Я не знаю как
Автор: sfunlimit
Дата сообщения: 21.07.2011 16:47
Интерфейсы подняты. FE 0/0 на каждом маршрутизаторе стоит UP
Автор: sfunlimit
Дата сообщения: 01.08.2011 11:15
Пардон, не фига интерфейсы не подняты =( продолжаю читать умный книжки...

Добавлено:
Прошу прощения что сразу не отписался. Просто я новичок. Самостоятельно пытаюсь изучить CISCO читаю CCNA 1-2 добрался до настройки маршрутизаторов а там косяки за косяком.
Скачал с оф сайта. GNS3 all in one.
С вашего сайта взял образы.
Поставил сконфигурировал. сохранил. После сохранения конфигурации записывает в NVRAM и должен уйти на ребут. Но вместо этого тупо виснет.
IDLPC настроил так что показывает 3%.
Проц Core 2 Quad q8200 - загрузка цп 3%
озу 2гб занято 1.1
Виснет на образах 2960 и3600.
Вот нашёл что то с ошибкой.

BIST FAILED...
Unknown file system detected.
Use format command to format the card as DOS File System.
Or use erase command to format the card as Low End File System.
У меня с английским не очень - обнаружена неизвестная файловая система. отформатируйте диск в типа в режиме DOS или используйте низкоуровневый формат.
Это можно сделать на GNS?
Может проблем в ОС у меня стоит Win7
у хардов формат NTFS

Может у кого есть какие нибудь мысли?
Или поделитесь пожалуйста у кого на каких ОС работают GNS и динамипс.
Заранее спасибо с Уважением Евгений.
Автор: sfunlimit
Дата сообщения: 02.08.2011 08:23
BIST FAILED...
Unknown file system detected.
Решено.

Проблема была в сжатом или неполном образе.
Скачал другой образ "2691" по объёму больше в два раза, всё работает.
Автор: sfunlimit
Дата сообщения: 29.09.2011 10:19
Возникла трабла
схема
- маршрутизаторы 1-2-3 расположены в одной сети 192.168.0.0.
- маршрутизаторы подключены так "м1 с IP" 0.5<->0.4 "м2 с IP" 0.3 <-> 0.2 "м1 с IP" 0.1
Проблема в том что пингуются только граничащие маршрутизаторы т.е. м1 видит м2 но не видит м3 и с м3 тоже самое. м2 видит оба маршрутизатора.
Что я не так делаю или это недочёт GNS3 какой то?
Спросил у знакомого он сказал что их там хоть двести может быть. Если они в одной сети то видеть должны друг друга.

скрин схемы---
http://s43.radikal.ru/i099/1109/3f/8d513de6f914.png
Автор: vlary
Дата сообщения: 29.09.2011 10:23
sfunlimit
Цитата:
маршрутизаторы 1-2-3 расположены в одной сети 192.168.0.0.

По нарисованной схеме они не могут быть в одной сети.
Цитата:
Что я не так делаю или это недочёт GNS3 какой то?

На роутере м2 объединить интерфейсы к первому и третьему роутерам в бридж.
Автор: sfunlimit
Дата сообщения: 29.09.2011 10:46
Задачу понял. Спасибо vlary.
А как сделать чтобы они были в одной сети?
Автор: vlary
Дата сообщения: 29.09.2011 11:49
sfunlimit
Цитата:
А как сделать чтобы они были в одной сети?
Либо просто вместо цепочки сделать подключение типа "звезда", либо, как я уже написал, на среднем роутере создать бридж. И выдать интерфейсу м1, интерфейсу (бриджу во втором случае) м2 и интерфейсу м3 адреса из сети 192.168.0.0 с одинаковой маской (255.255.255.0 или 255.255.0.0).

Автор: sfunlimit
Дата сообщения: 29.09.2011 12:12

Цитата:
vlary


вот по быстрому накидал...
http://s55.radikal.ru/i147/1109/a4/0bc0b192d898.png


ps в такой схеме всё хорошо друг друга видит и работает. Теперь попробую бриджом сделать. Спасибо за ответ.
Автор: sfunlimit
Дата сообщения: 04.10.2011 15:18
Всем привет то снова я.
Бьюсь третий день. не знаю что делать.
В схеме нарисованой выше. Маршрутизаторы пингуются и прекрасно видят друг друга (IP адреса у каждого 0.1 0.2 --0.3 0.4 и тд.). прописываю на первом - ip route 0.0.0.0 0.0.0.0 192.168.0.10 маршрутизаторы видят друг друга, но дальше не идут. Что я не так делаю?

.... аналогично 0.0.0.0 0.0.0.0 fastethernet 0/0
Сейчас ещё одну фигню попробую...
попробовал собрать в цепочку как написано в учебнике страница в PDF 762. В книге 760. Часть II. Курс CCNA2: маршрутизаторы и основы маршрутизации


interface FastEthernet0/0
ip address 192.168.2.2 255.255.255.0
no ip route-cache
speed auto
full-duplex
no mop enabled
!
interface Serial0/0
no ip address

Dva#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Dva(config)#ip route
Dva(config)#ip route 192.168.0.0 255.255.255.0 fas
Dva(config)#ip route 192.168.0.0 255.255.255.0 fastEthernet 0/0
Dva(config)#^Z
Dva#wr
Building configuration...

Пинги с первого маршрутизатора
Dva#ping 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Пинги со второго.
First#ping 192.168.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
First#

Скрин схемы - http://s05.radikal.ru/i178/1110/c2/07537f420d5c.png
схема построена R3-IP 192.168.3.2 <---> IP 192.168.3.1 (R2) 192.168.2.2 <---> 192.168.2.1 (R1) 192.168.0.1 <----> world 192.168.0.10
Маршрутизаторы в такой схеме друг друга не видят и не пингуются, первый маршрутизатор видит мир. Скажите что я не так делаю или так и должно быть и есть какая толковая литература которая бы поясняла такие моменты. Спасибо.

Если надо могу выслать конфиги маршрутизаторов. Уже голову сломал. Думал дальше напишут что может быть так они друг друга не видят а результат будет виден после маршрутизации а там дальше другие лабы. Помогите пожалуйста.
Автор: Valery12
Дата сообщения: 04.10.2011 15:54

Цитата:
схема построена R3-IP 192.168.3.2 <---> IP 192.168.3.1 (R2) 192.168.2.2 <---> 192.168.2.1 (R1) 192.168.0.1 <----> world 192.168.0.10

R3
ip route 0.0.0.0 0.0.0.0 192.168.3.1

R2
ip route 0.0.0.0 0.0.0.0 192.168.2.1

R1
ip route 0.0.0.0 0.0.0.0 192.168.0.10
ip route 192.168.3.0 255.255.255.0 192.168.2.2

world
ip route 0.0.0.0 0.0.0.0 ?
ip route 192.168.2.0 255.255.255.0 192.168.0.1
ip route 192.168.3.0 255.255.255.0 192.168.0.1

или если world это интернет, то на R1 включить NAT
Автор: sfunlimit
Дата сообщения: 05.10.2011 13:42
Valery12
Спасибо большое. сейчас буду пробовать. о результатах напишу.

Добавлено:
Valery12
Не выходит =( я что то не так сделал или не так настроил..
Конфиг R2 Взгляните у меня тут затуп по ходу....

Dva#show run
Building configuration...

Current configuration : 1310 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Dva
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$AaWf$0WUOoIrjFtxtdQSzjNhIn/
enable password 7 13291C010A180B2F7A
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
archive
log config
hidekeys
!
!
interface FastEthernet0/0
ip address 192.168.2.2 255.255.255.0
no ip route-cache
speed auto
full-duplex
no mop enabled
!
interface Serial0/0
no ip address
no ip route-cache
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.3.1 255.255.255.0
no ip route-cache
speed auto
full-duplex
!
interface Serial0/1
no ip address
no ip route-cache
shutdown
clock rate 2000000
!
interface Serial0/2
no ip address
no ip route-cache
shutdown
clock rate 2000000
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.2.1
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
password 7 03285018071B2E491F51
login
!
!
end
Автор: Valery12
Дата сообщения: 05.10.2011 14:12
лучше "sh ip route" с R1, R2, R3
Автор: sfunlimit
Дата сообщения: 05.10.2011 15:45
TRI#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.3.1 to network 0.0.0.0

C 192.168.3.0/24 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 192.168.3.1
_____________________________________________________

Dva#sh ip route
Default gateway is not set

Host Gateway Last Use Total Uses Interface
ICMP redirect cache is empty
--------------------------------------------------------------------------

First#sh ip route
Default gateway is not set

Host Gateway Last Use Total Uses Interface
ICMP redirect cache is empty
опаньки =( у меня на втором и первом почему то пусто... почему на третьем прописался путь а на втором нет? когда набираешь на r2 sh run
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.2.1
показывает что путь есть. что я не так делаю?
сори что так долго по работе отвлекался =(
Автор: Valery12
Дата сообщения: 05.10.2011 20:05
похоже роутинг выключен, выполни на первом и втором
в режиме глобальной конфигурации
ip routing
Автор: sfunlimit
Дата сообщения: 06.10.2011 08:04
Valery12
Доброе утро.
Маршрутизация прописалась но пинги не ходют, вобще никак, друг друга не видят. Только первый маршрутизатор .0.10 видит.

First#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.0.10 to network 0.0.0.0

C 192.168.0.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, FastEthernet0/1
S 192.168.3.0/24 [1/0] via 192.168.2.2
S* 0.0.0.0/0 [1/0] via 192.168.0.10
--------------------------------------------------------------------

Dva#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.2.1 to network 0.0.0.0

C 192.168.2.0/24 is directly connected, FastEthernet0/0
C 192.168.3.0/24 is directly connected, FastEthernet0/1
S* 0.0.0.0/0 [1/0] via 192.168.2.1
---------------------------------------------------------------------

TRI#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.3.1 to network 0.0.0.0

C 192.168.3.0/24 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 192.168.3.1
Автор: Valery12
Дата сообщения: 06.10.2011 08:33
Теперь маршрутизация на R1, R2, R3 настроена правильно

Цитата:
Только первый маршрутизатор .0.10 видит.

это потому что нет маршрутов на 192.168.0.10
тогда как я уже писал
Цитата:
world
ip route 0.0.0.0 0.0.0.0 ?
ip route 192.168.2.0 255.255.255.0 192.168.0.1
ip route 192.168.3.0 255.255.255.0 192.168.0.1

или если world это интернет, то на R1 включить NAT

Автор: sfunlimit
Дата сообщения: 07.10.2011 08:11
Valery12
Сори что так долго не отвечал. Сервар упал с Exchange. Вчера весь день с ним возились. Сейчас сделаю всё и напишу что у меня вышло.

Добавлено:
Valery12
Доброе утро.
0\0 выходит в реальную сеть т.е., в мой комп, в котором стоит сетевая "на себя"
0\1 как посхеме в следующий роутер.
Всё равно пинги не ходят между собой и 0.10 так же не пингуется.
!
interface FastEthernet0/0
description Path cloud real network
ip address 192.168.0.1 255.255.255.0
ip nat outside
ip virtual-reassembly
speed auto
full-duplex
no mop enabled
!

!
interface FastEthernet0/1
description Path to virt ROUTER's
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
speed auto
full-duplex
!
Автор: Valery12
Дата сообщения: 07.10.2011 11:28

Цитата:
0\0 выходит в реальную сеть т.е., в мой комп, в котором стоит сетевая "на себя"
значит 192.168.0.10 это адрес сетевой "на себя"?
тогда маршруты
ip route 192.168.2.0 255.255.255.0 192.168.0.1
ip route 192.168.3.0 255.255.255.0 192.168.0.1
нужно добавлять на своем компьютере
если на R1 включен NAT то где остальные настройки, пулл, ACL для доступа?
и что значит
Цитата:
Всё равно пинги не ходят между собой

между R1 R2 и R3 пинги не ходят? Тогда дело не в настройках маршрутизации
давай со всех sh ip int bri

Страницы: 12

Предыдущая тема: настройка ssh-туннеля


Форум Ru-Board.club — поднят 15-09-2016 числа. Цель - сохранить наследие старого Ru-Board, истории становления российского интернета. Сделано для людей.