[more] Я пытаюсь ограничить использование ТОR, посредством закидывания в address-list адресов из
https://www.dan.me.uk/torlist/ Для этого раз в час запускается следующий скрипт, утянутый с вики микротика
Код: /tool fetch dst-path=TOR-NODES-LIST.txt mode=https url="https://www.dan.me.uk/torlist/"
:if ( [/file get [/file find name=TOR-NODES-LIST.txt] size] > 0 ) do={
# Remove exisiting addresses from the current Address list
/ip firewall address-list remove [/ip firewall address-list find list=TOR-NODES-LIST]
:global content [/file get [/file find name=TOR-NODES-LIST.txt] contents] ;
:global contentLen [ :len $content ] ;
:global lineEnd 0;
:global line "";
:global lastEnd 0;
o {
:set lineEnd [:find $content "\n" $lastEnd ] ;
:set line [:pick $content $lastEnd $lineEnd] ;
:set lastEnd ( $lineEnd + 1 ) ;
#If the line doesn't start with a hash then process and add to the list
:if ( [:pick $line 0 1] != "#" ) do={
:local entry [:pick $line 0 ($lineEnd -1) ]
:if ( [:len $entry ] > 0 ) do={
/ip firewall address-list add list=MY-IP-LIST address=$entry
}
}
} while ($lineEnd < $contentLen)
}