version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot system flash c870-advipservicesk9-mz.150-1.M1.bin
boot-end-marker
!
logging buffered 51200 informational
!
no aaa new-model
!
!
!
clock timezone MSK 3
clock summer-time MSK recurring last Sun Mar 2:00 last Sun Oct 3:00
clock save interval 8
!
crypto pki trustpoint tti
revocation-check crl
rsakeypair tti
!
crypto pki trustpoint TP-self-signed-<cert>
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-<cert>
revocation-check none
rsakeypair TP-self-signed-<cert>
!
!
crypto pki certificate chain tti
crypto pki certificate chain TP-self-signed-<cert>
certificate self-signed 01 nvram:IOS-Self-Sig#E.cer
dot11 syslog
!
dot11 ssid 877W
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 7 <wpapsw>
!
ip source-route
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.2
ip dhcp excluded-address 192.168.1.3
ip dhcp excluded-address 192.168.1.4
ip dhcp excluded-address 192.168.1.5
ip dhcp excluded-address 192.168.1.6
ip dhcp excluded-address 192.168.1.7
ip dhcp excluded-address 192.168.1.8
ip dhcp excluded-address 192.168.1.9
!
ip dhcp pool 877W
network 192.168.1.0 255.255.255.0
dns-server 212.188.4.10 195.34.32.116
default-router 192.168.1.1
!
!
ip cef
ip domain name mtu.ru
ip name-server 212.188.4.10
ip name-server 195.34.32.116
ip inspect name DEFAULT100 cuseeme
ip inspect name DEFAULT100 ftp
ip inspect name DEFAULT100 h323
ip inspect name DEFAULT100 icmp
ip inspect name DEFAULT100 netshow
ip inspect name DEFAULT100 rcmd
ip inspect name DEFAULT100 realaudio
ip inspect name DEFAULT100 rtsp
ip inspect name DEFAULT100 esmtp
ip inspect name DEFAULT100 sqlnet
ip inspect name DEFAULT100 streamworks
ip inspect name DEFAULT100 tftp
ip inspect name DEFAULT100 tcp
ip inspect name DEFAULT100 udp
ip inspect name DEFAULT100 vdolive
ip inspect name DYN_PORTS tcp router-traffic timeout 300
ip ddns update method mike-dyndns
HTTP
add
http://<L>:<P>@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a> remove
http://<L>:<P>@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a> interval maximum 28 0 0 0
!
no ip igmp snooping
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
username Mike privilege 15 secret 5 <SECPSW>
!
!
!
class-map match-all TV
match ip dscp cs4
class-map match-all SCAV
match ip dscp cs1
class-map match-all P2P
match protocol bittorrent
!
!
policy-map P2P
class P2P
set dscp cs1
policy-map my-LLQ
class TV
priority 4800
class SCAV
class class-default
fair-queue
random-detect dscp-based
!
!
!
!
!
bridge irb
!
!
!
interface ATM0
description WAN
no ip address
no atm ilmi-keepalive
!
!
interface ATM0.1 point-to-point
description Stream Internet
pvc 1/50
pppoe-client dial-pool-number 1
!
!
interface ATM0.2 point-to-point
description VoD
bridge-group 2
bridge-group 2 spanning-disabled
pvc 1/91
encapsulation aal5snap
!
!
interface ATM0.3 point-to-point
description TV
bridge-group 2
bridge-group 2 spanning-disabled
pvc 1/92
encapsulation aal5snap
!
!
interface FastEthernet0
description 2Switch
spanning-tree portfast
!
service-policy output my-LLQ
!
interface FastEthernet1
description Amino
switchport access vlan 2
no keepalive
spanning-tree portfast
!
service-policy output my-LLQ
!
interface FastEthernet2
description 2MikePC
switchport access vlan 2
spanning-tree portfast
!
service-policy output my-LLQ
!
interface FastEthernet3
description 2EugenePC
switchport access vlan 2
spanning-tree portfast
!
service-policy output my-LLQ
!
interface Dot11Radio0
description WiFi Access Point
no ip address
!
encryption mode ciphers tkip
!
ssid 877W
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
world-mode dot11d country RU both
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
!
interface Vlan1
description description Ethernet&WiFi
no ip address
bridge-group 1
!
!
interface Vlan2
description TV
no ip address
bridge-group 2
bridge-group 2 spanning-disabled
!
!
interface Dialer0
bandwidth 10240
ip ddns update hostname <>.homedns.org
ip ddns update mike-dyndns host members.dyndns.org
ip address negotiated
ip access-group 101 in
ip mtu 1492
ip flow ingress
ip flow egress
ip nat outside
ip inspect DYN_PORTS out
ip virtual-reassembly max-reassemblies 128
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname <L>
ppp chap password 7 <P>
no cdp enable
!
service-policy input P2P
!
interface BVI1
description LAN
bandwidth 10240
ip address 192.168.1.1 255.255.255.0
ip access-group 100 in
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip flow-cache timeout active 1
ip flow-export version 5
ip flow-export destination 192.168.1.2 9999
ip flow-top-talkers
top 5
sort-by bytes
cache-timeout 3600
!
ip dns server
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 192.168.1.9 80 interface BVI1 80
ip nat inside source static tcp 192.168.1.9 443 interface BVI1 443
ip nat inside source static tcp 192.168.1.9 5223 interface BVI1 5223
ip nat inside source static udp 192.168.1.9 3478 interface BVI1 3478
ip nat inside source static udp 192.168.1.9 3479 interface BVI1 3479
ip route 0.0.0.0 0.0.0.0 Dialer0
!
kron occurrence TIME in 2:0 recurring
kron policy-list TIME
cli ntp server nist.time.gov source di0 prefer
!
logging facility local0
logging 192.168.1.2
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 100 remark CCP_ACL Category=17
access-list 100 remark Auto generated by SDM for NTP (123) time.nist.gov
access-list 100 permit udp host 192.43.244.18 eq ntp host 192.168.1.1 eq ntp
access-list 100 deny ip host 255.255.255.255 any
access-list 100 permit ip any any
access-list 100 permit icmp any any
access-list 101 remark CCP_ACL Category=17
access-list 101 remark Auto generated by SDM for NTP (123) time.nist.gov
access-list 101 permit udp host 192.43.244.18 eq ntp any eq ntp
access-list 101 permit udp host 212.188.4.10 eq domain any
access-list 101 permit udp host 195.34.32.116 eq domain any
access-list 101 deny ip 192.168.1.0 0.0.0.255 any
access-list 101 permit icmp any any echo-reply
access-list 101 permit icmp any any time-exceeded
access-list 101 permit icmp any any unreachable
access-list 101 deny ip 10.0.0.0 0.255.255.255 any
access-list 101 deny ip 172.16.0.0 0.15.255.255 any
access-list 101 deny ip 192.168.0.0 0.0.255.255 any
access-list 101 deny ip 127.0.0.0 0.255.255.255 any
access-list 101 deny ip host 255.255.255.255 any
access-list 101 deny ip host 0.0.0.0 any
access-list 101 deny ip any any
dialer-list 1 protocol ip permit
!
!
!
!
snmp-server community mikesnmp RW
snmp-server ifindex persist
snmp-server host 192.168.1.2 <P>
snmp-server host 192.168.1.2 version 2c mikesnmp
!
control-plane
!
!
bridge 1 protocol ieee
bridge 1 route ip
banner login Cisco 877W access router ready
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
access-class 23 in
login local
length 0
transport input telnet ssh
!
scheduler max-task-time 5000
ntp logging
ntp server time.nist.gov prefer source Dialer0
sntp logging
end