Доброго времени суток!
Помогите, пожалуйста, настроить ВПН так, чтобы клиенты ВПН получали доступ во внутреннюю сеть.
Сразу скажу, что пару лет назад пытался настроить резервное переключение каналов Инета, и пытался настроить ВПН средствами SDM, по этому информация несколько избыточна.
[more=service timestamps debug datetime msec]
service timestamps log datetime msec
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname cisco1841
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 $1$bHXM$YfQPK3qv3H6m9hVVf/nsE.
enable password 7 04590E14082D454107
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login ciscocp_vpn_xauth_ml_1 local
aaa authentication ppp default local
aaa authorization exec default local
aaa authorization network default if-authenticated
aaa authorization network ciscocp_vpn_group_ml_1 local
!
aaa session-id common
no ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
no ip dhcp use vrf connected
!
ip dhcp pool LAN_DHCP
network 192.168.0.0 255.255.255.0
default-router 192.168.0.50
dns-server 212.188.4.10 195.34.32.116 81.200.0.1 81.200.2.222
domain-name Pro
!
!
ip domain name yourdomain.com
ip name-server 212.188.4.10
ip name-server 195.34.32.116
ip name-server 81.200.0.1
ip name-server 81.200.2.222
vpdn enable
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
protocol pptp
virtual-template 1
!
!
!
crypto pki trustpoint TP-self-signed-1000422412
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1000422412
revocation-check none
rsakeypair TP-self-signed-1000422412
!
!
crypto pki certificate chain TP-self-signed-1000422412
certificate self-signed 01
30820250 308201B9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
5A4FD95B 53472798 A3AF79E1 F447F9DF DD4E5C8D
quit
username see privilege 15 password 7 0509031D2640470617
username administrator privilege 15 secret 5 $1$7CJi$LOnQHghKHV9cS111jX25p1
username test password 7 071B245F5A
username dva privilege 15 password 7 095C4F1A0A1218000F
archive
log config
hidekeys
!
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp client configuration address-pool local SDM_POOL_1
!
crypto isakmp client configuration group EasyVPN
key 123456789
dns 192.168.0.2
domain prof
pool SDM_POOL_1
include-local-lan
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
!
crypto dynamic-map SDM_DYNMAP_1 1
set transform-set ESP-3DES-SHA
reverse-route
!
!
crypto map SDM_CMAP_1 client authentication list ciscocp_vpn_xauth_ml_1
crypto map SDM_CMAP_1 isakmp authorization list ciscocp_vpn_group_ml_1
crypto map SDM_CMAP_1 client configuration address respond
crypto map SDM_CMAP_1 65535 ipsec-isakmp dynamic SDM_DYNMAP_1
!
!
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
description Lan
ip address 192.168.0.50 255.255.255.0
ip nat inside
ip virtual-reassembly
speed auto
full-duplex
no mop enabled
!
interface FastEthernet0/1
description Inet$ETH-WAN$
ip address xx.xx.170.46 255.255.255.252
ip nat outside
ip virtual-reassembly
ip policy route-map RMAP_NAT_FA0/1
duplex auto
speed auto
crypto map SDM_CMAP_1
!
interface FastEthernet0/0/0
description InetSU29
!
interface Virtual-Template1
ip unnumbered FastEthernet0/0
ip nat inside
ip virtual-reassembly
autodetect encapsulation ppp
peer default ip address pool VPN
no keepalive
ppp encrypt mppe auto
ppp authentication pap chap ms-chap
!
interface Vlan1
description InetSU29
ip address xx.xx.17.5 255.255.255.0
ip nat outside
ip virtual-reassembly
ip policy route-map RMAP_NAT_FA0/0/0
!
ip local pool VPN 192.168.10.100 192.168.10.150
ip local pool SDM_POOL_1 192.168.0.151 192.168.0.200
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 xx.xx.170.45
ip route 0.0.0.0 0.0.0.0 xx.xx.17.1 2
ip route 192.168.10.0 255.255.255.0 FastEthernet0/0
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source route-map RMAP_NAT_FA0/0/0 interface Vlan1 overload
ip nat inside source route-map RMAP_NAT_FA0/1 interface FastEthernet0/1 overload
ip dns server
!
access-list 1 permit 192.168.10.0 0.0.0.255 log
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 10 permit any
route-map RMAP_NAT_FA0/0/0 permit 100
match ip address 1
match interface Vlan1
set ip next-hop xx.xx.17.1
!
route-map RMAP_NAT_FA0/1 permit 50
match ip address 1
match interface FastEthernet0/1
set ip next-hop xx.xx.170.45
![/more]
Помогите, пожалуйста, настроить ВПН так, чтобы клиенты ВПН получали доступ во внутреннюю сеть.
Сразу скажу, что пару лет назад пытался настроить резервное переключение каналов Инета, и пытался настроить ВПН средствами SDM, по этому информация несколько избыточна.
[more=service timestamps debug datetime msec]
service timestamps log datetime msec
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname cisco1841
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 $1$bHXM$YfQPK3qv3H6m9hVVf/nsE.
enable password 7 04590E14082D454107
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login ciscocp_vpn_xauth_ml_1 local
aaa authentication ppp default local
aaa authorization exec default local
aaa authorization network default if-authenticated
aaa authorization network ciscocp_vpn_group_ml_1 local
!
aaa session-id common
no ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
no ip dhcp use vrf connected
!
ip dhcp pool LAN_DHCP
network 192.168.0.0 255.255.255.0
default-router 192.168.0.50
dns-server 212.188.4.10 195.34.32.116 81.200.0.1 81.200.2.222
domain-name Pro
!
!
ip domain name yourdomain.com
ip name-server 212.188.4.10
ip name-server 195.34.32.116
ip name-server 81.200.0.1
ip name-server 81.200.2.222
vpdn enable
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
protocol pptp
virtual-template 1
!
!
!
crypto pki trustpoint TP-self-signed-1000422412
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1000422412
revocation-check none
rsakeypair TP-self-signed-1000422412
!
!
crypto pki certificate chain TP-self-signed-1000422412
certificate self-signed 01
30820250 308201B9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
5A4FD95B 53472798 A3AF79E1 F447F9DF DD4E5C8D
quit
username see privilege 15 password 7 0509031D2640470617
username administrator privilege 15 secret 5 $1$7CJi$LOnQHghKHV9cS111jX25p1
username test password 7 071B245F5A
username dva privilege 15 password 7 095C4F1A0A1218000F
archive
log config
hidekeys
!
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp client configuration address-pool local SDM_POOL_1
!
crypto isakmp client configuration group EasyVPN
key 123456789
dns 192.168.0.2
domain prof
pool SDM_POOL_1
include-local-lan
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
!
crypto dynamic-map SDM_DYNMAP_1 1
set transform-set ESP-3DES-SHA
reverse-route
!
!
crypto map SDM_CMAP_1 client authentication list ciscocp_vpn_xauth_ml_1
crypto map SDM_CMAP_1 isakmp authorization list ciscocp_vpn_group_ml_1
crypto map SDM_CMAP_1 client configuration address respond
crypto map SDM_CMAP_1 65535 ipsec-isakmp dynamic SDM_DYNMAP_1
!
!
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
description Lan
ip address 192.168.0.50 255.255.255.0
ip nat inside
ip virtual-reassembly
speed auto
full-duplex
no mop enabled
!
interface FastEthernet0/1
description Inet$ETH-WAN$
ip address xx.xx.170.46 255.255.255.252
ip nat outside
ip virtual-reassembly
ip policy route-map RMAP_NAT_FA0/1
duplex auto
speed auto
crypto map SDM_CMAP_1
!
interface FastEthernet0/0/0
description InetSU29
!
interface Virtual-Template1
ip unnumbered FastEthernet0/0
ip nat inside
ip virtual-reassembly
autodetect encapsulation ppp
peer default ip address pool VPN
no keepalive
ppp encrypt mppe auto
ppp authentication pap chap ms-chap
!
interface Vlan1
description InetSU29
ip address xx.xx.17.5 255.255.255.0
ip nat outside
ip virtual-reassembly
ip policy route-map RMAP_NAT_FA0/0/0
!
ip local pool VPN 192.168.10.100 192.168.10.150
ip local pool SDM_POOL_1 192.168.0.151 192.168.0.200
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 xx.xx.170.45
ip route 0.0.0.0 0.0.0.0 xx.xx.17.1 2
ip route 192.168.10.0 255.255.255.0 FastEthernet0/0
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source route-map RMAP_NAT_FA0/0/0 interface Vlan1 overload
ip nat inside source route-map RMAP_NAT_FA0/1 interface FastEthernet0/1 overload
ip dns server
!
access-list 1 permit 192.168.10.0 0.0.0.255 log
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 10 permit any
route-map RMAP_NAT_FA0/0/0 permit 100
match ip address 1
match interface Vlan1
set ip next-hop xx.xx.17.1
!
route-map RMAP_NAT_FA0/1 permit 50
match ip address 1
match interface FastEthernet0/1
set ip next-hop xx.xx.170.45
![/more]