Ru-Board.club
← Вернуться в раздел «В помощь системному администратору»

» Microsoft SharePoint Server

Автор: KD_max
Дата сообщения: 29.02.2008 11:45
Здраствуйте. Есть такая проблема: имеется SPS 2003, внутри локальной сети работает всё замечательно. Пробую опубликовать через ISA 2006 с помощью соответсвующего мастера. В правиле прописываю URL для доступа из вне corp.org. На вкладке Куда указываю имя компьютера с SPS (в AD) - sps.domain.local. При попытке доступа из Интернета, обозреватель выдает окно авторизации, после прохождения которой выдается ошибка о том, что нельзя найти доменное имя sps.domain.local. По логам ISA видно, что при обращении к corp.org ISA после верной авторизации начинает искать сервер с SPS (sps.domain.local) у внешнего DNS, а не на внутреннем. Может кто сталкивался с такой проблемой? Подскажите пожалуйста что не так настроено
Автор: ZeBBit
Дата сообщения: 29.02.2008 12:03
KD_max
В файле hosts на isa сервере надо прописать corp.org=внутренний IP адрес вашего сервера sps.domain.local. Возможно, для корректной работы поиска и ссылок на sps надо будет настроить Link Translation в правиле публикации портала, а также в настройках портала прописать внешнее имя в Alternate Address mapping.
Автор: e32
Дата сообщения: 29.02.2008 13:35
Как создавать личные сайты
Нужна помощь.
Что делаю:
- добавляю управляемый путь http://портал/sites как явный (без подстановок) впрочем пытался и с подстановками;
- в приложении создаю узел по указанному пути по шаблону "корпоративный-расположение личных узлов"; все ОК, узел работает.
- в администрировании общих служб задаю параметры личных узлов:
1. портал и путь /sites, формат имен - без конфликтов, глобальное развертывание запрещено, т.к. служба одна.
2. надежные места для размещения личных узлов заданы как http://портал/sites, там же заданы разрешения (в данном случае - полные);

Захожу на портал с правами дальше некуда. При нажатии "Мой узел" идет попытка создания личного узла. Сообщение "Запрос на выполнение скриптов" и система зависает на неопределенное время. В итоге - личный сайт не создан, по тайм-ауту операция прервана.
Пробовал разными пользователями, в.т.ч. владелец узла.

ЧТО делаю не так или что не делаю так как надо.
Плз., ХеЛп
Спасибо.

В догонку: имеется Системная учетная запись SHAREPOINT\system
Как отредактировать учетные параметры этой записи. В лоб не дается.
Автор: fsv2k5
Дата сообщения: 29.02.2008 17:02
e32
вместо sites укажи personal
sites используются для создания узлов
Автор: KD_max
Дата сообщения: 02.03.2008 15:17
ZeBBit
Проблема была в другом, но всё равно спасибо за помощь.

Есть ещё такой "глобальный" вопрос для тех кто занимался SharePoint: сколько по длительности занимает этап внедрения SharePoint с нуля на предприятии? Т.е. сколько примерно проходит времени с момента начала установки портала (не важно какой версии) до момента, когда можно говорить о том, что документооборот на предприятии по большей части происходит с помощью SharePoint?
Автор: qwarez
Дата сообщения: 03.03.2008 13:55
документооборот это одно
шарепоинт несколько больше по возможностям
==
техническая часть, осообенно без доработок, = месяц
а вот документооборот = годы - и тут что ШП, что Documentum, что Smarteam что еще какая приблуда не имеет особого значения.
Автор: fsv2k5
Дата сообщения: 03.03.2008 15:54
для документооборота необходимо описать процессы, и сразу все станет наглядно понятно
Автор: Collapse Troll
Дата сообщения: 05.03.2008 19:50
Не подскажете, как на портале wss 3.0 включить всплывающие подсказки(tooltips) при наведении на элементы списков? Вроде бы где-то видел такое, но не знаю где включить.
Автор: Collapse Troll
Дата сообщения: 10.03.2008 23:57
Здравствуйте!

Есть узел sharepoint с документами. В администраторы узла добавлены два пользователя(все машины в домене). Один администратор загружает документы в библиотеку, другой их не видит. Права у пользователей одинаковых(can read, change, delete). Файлы не скрытые. В чем может быть дело?
Автор: mimchik
Дата сообщения: 13.03.2008 16:06
ralexa


Цитата:
Вопрос первый - на кой тебе людей искать? это тебе не live/comminicator server...
Вопрос второй - а ты указал в настройках БД что её необходимо индексировать и если да то сколько подождал после включения данной опции, какие у неё настройки (как частно индексировать) и какой объём самой БД???


На первый, есть вэб части в которых надо людей найти и раздать им права, согласно принадлежности к отделу или подчинености определенному челу. Так как поиск не работает то и эа вэб часть не пашет.

На второй:
Если имеешь ввиду
Код: Администрирование общих служб: SharedServices1 > Параметры поиска
Автор: FreemanRU
Дата сообщения: 14.03.2008 13:55
Collapse Troll

Цитата:
В администраторы узла добавлены два пользователя(все машины в домене). Один администратор загружает документы в библиотеку, другой их не видит. Права у пользователей одинаковых(can read, change, delete). Файлы не скрытые. В чем может быть дело?

Скорее всего в библиотеке стоит настройка "чтение только своих элементов"
Автор: Collapse Troll
Дата сообщения: 14.03.2008 15:46
FreemanRU
оппааа... а где можно найти ее? захожу в Параметры узла-> Библиотеки и списки узла -> выбираю библиотеку, не вижу такой настройки. версия wss 3.0
Автор: FreemanRU
Дата сообщения: 14.03.2008 15:52
Collapse Troll
Упс, это я со списком перепутал. А утверждение элементов не включено в этой библиотеке?
Обрати внимание на параметр "Безопасность для черновиков" в "Управление версиями".
Автор: plasticman
Дата сообщения: 14.03.2008 18:27
Скажите как экспортировать веб часть из Visual Web Developer. Потом его надо будет импортировать в шерпоинт. Или сразу в шерпоинте его как-то сделать можно? С таким же удобным интерфейсом как и в девелопере.
Автор: JannLee
Дата сообщения: 14.03.2008 20:07
Такой вопрос. SharePoint 2007 будет работать если на всех машинах стоит Office 2003 SP3. Только на личных ноутах у некоторых стоит Office 2007. Необходима совместимость с Office 2003 Pro SP3 и Office 2007, однако Office 2003 важней так как стоит у шефа.
Автор: FreemanRU
Дата сообщения: 14.03.2008 21:53
JannLee

Цитата:
SharePoint 2007 будет работать если на всех машинах стоит Office 2003 SP3

Будет
Автор: mimchik
Дата сообщения: 17.03.2008 09:43
JannLee


Цитата:
Такой вопрос. SharePoint 2007 будет работать если на всех машинах стоит Office 2003 SP3.

Будет, но могут возникнуть проблемы с извлечением файлов с портала, для этого достаточно поставить общие компоненты офиса 2007, там есть что-то про доуступ к SPS 2007.
Автор: Collapse Troll
Дата сообщения: 18.03.2008 19:12
Здравствуйте!

Подскажите пожалуйста, как грамотно восстановить sharepoint-овские базы SQL(Используются сервисы wss 3.0).

Делаю так:
- останавливаю процессы sharepoint-а из центра администрирования в Central Administration > Operations > Services on Server, стопорю все.
- используя SQL Server Management Studio Express бэкапирую все базы sharepoint-а
- ресторю базы SQL на другой машине(на самом деле это копия той же виртуальной машины, настройки те же)

После старта служб на новой машине зайти на сайт sharepoint-а не могу(в центр администрирования можно). При попытке переконфигурировать через SharePoint Products and Technologies Configuration Wizard получаю ошибку

"An update conflict has occurred, and you must re-try this action". Решение описываемое в
http://support.microsoft.com/kb/939308
мне не подходит, у меня нет таких папок которые в нем предлагается удалять.

1) Чего-то в моих действиях не хватает?

2) Вычитал про другоЙ вид бэкапирования, утилитой stsadm.exe. Возникает второй вопрос:
при попытке бэкапировать подузел stsadm ругается, что бэкапировать можно только root узел. Как же так, получается нет способа перенести только определенные узлы на другой сервер?
Автор: mimchik
Дата сообщения: 19.03.2008 10:14
Странно, вообще можно бэкапить узлы, а не пробовал бэкапить из администрирования? Там все ясно сказано
Автор: Collapse Troll
Дата сообщения: 19.03.2008 11:02

Цитата:
Странно, вообще можно бэкапить узлы, а не пробовал бэкапить из администрирования?
mimchik
пробовали. При бэкапировании любой баз с ней вместе с ошибкой бэкапируется SharedServices1, получаем такой результат:

Цитата:
Object SharedServices1 failed in event OnPrepareBackup. For more information, see the error log located in the backup directory.


Цитата:
Failure message:
Object SharedServices1 failed in event OnPrepareBackup. For more information, see the error log located in the backup directory. DllNotFoundException: Unable to load DLL 'Microsoft.Office.Server.Native.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)

После восстановлении также нелья зайти на страницу sharepoint
Автор: mimchik
Дата сообщения: 19.03.2008 17:12
А искать файлик требуемый не пробовали? может в нем косяк....
Автор: ralexa
Дата сообщения: 19.03.2008 21:55
Народ кто сталкивался подскажите как можно управлять оповещениями на сайте ?
Есть список, на него навешивается несколько типов оповещений в случае изменения контента (типа там если адресовано мне + все которые создал я и т.п.) и есть пеценденты когда на одно сообщение приходит 2 оповещения, что крайне не удобно, т.к. отдельным людям оповещения приходят чуть ли не каждые 2-5 минут... они отвечать толком не успевают ... а тут ещё такой спам идёт...
Кто как решал или предполягает решать такое???
Автор: remintnn
Дата сообщения: 20.03.2008 14:17
Подскажите с решением такой проблемы. Имеется WSS 3.0, домен и машины пользователей, не включенные в домен. Пользователи заходят на сервер WSS используя логины, прописанные в домене и на сервере WSS. С большинством проблем нет. А вот с некоторыми получается так. Они вводят пароль и через секунду IE снова запрашивает у них логин и пароль. Сервер WSS в логах пишет сначала, что вход удачный, а следующей записью: "Unknown user name or bad password". Причем так происходит только с IE, Firefox заходит нормально. Если используется логин администратора домена, то заходит и под IE. Со своего места у меня нормально логинятся проблемные учетки, хоть машина и не в домене. Подскажите, плиз!
Автор: ralexa
Дата сообщения: 20.03.2008 19:58
remintnn

Цитата:
Они вводят пароль и через секунду IE снова запрашивает у них логин и пароль.

Попробуй добавить в IE данный сайт в Trusted Sites (как по русски звучит не помню... но типа в доверительные ... ) обычно попускает в таких случаях, + если не попустит смотри на свою авторизацию (NTLM или Kerberos) поиграйся настроками в этом месте... у меня после таких манипуляций всё заработало...
Автор: remintnn
Дата сообщения: 21.03.2008 09:46
ralexa


В доверительные добавлял. Не работает. С NTLM или Kerberos попробую, спасибо!
Автор: StomA88
Дата сообщения: 24.03.2008 11:29
Всем Здрасти

Шарпоинт используем не так давно сам только начал разбираться и уперся в несколько проблем. Ну для начала опишем используем moss 2007 rus + sql 2005 + win 2003 r2 rus все пока на одной машине светит перенос но это пока отдельная песня.
Вобщем вопрос :
1 Установили шп настроил ферму (по книжке ) но при заходе внутри сети хттп://шп бросает сразу на профиль пользователя как сделать так чтобы бросал на созданый веб узел по шаблону ?
2 Опубликовали шп вродебы все красиво но при попытке создании или редактировании какого либо документа выдает ошибку "Файл не найден"

Помогите советом ткните носом в ошибки

Заранее спасибо.
Автор: ralexa
Дата сообщения: 24.03.2008 19:28
StomA88

Цитата:
при попытке создании или редактировании какого либо документа выдает ошибку "Файл не найден"

Сильно смахивает на права... или что то стало/настроено криво...
с первым вообще ни когда не сталкивался...
+ а нужен ли moss 2007 rus ??? может хватит wss 3.0??? мне хватило...
Автор: mimchik
Дата сообщения: 25.03.2008 17:16
StomA88
Такое впечатление что файлов шаблонов мало или вообще нет надо смотреть, думаю переустановка поможет.
Автор: KD_max
Дата сообщения: 28.03.2008 13:55
Вопрос по настройке почты: можно ли настроить исходящую почту в MOSS2007 на другой порт (не 25-й)? Если у кого был опыт, поделитесь
Автор: slayer120
Дата сообщения: 31.03.2008 17:20
Помогите решить проблему: работал w2k3 r1 сервер с mssql 2005 c sps 2007.
После лечения вирусов были удаленыи несколько exe sps2007 и sql.
После этого восстановил мастером восстановления 2007 офиса и скл.
Теперь страница администрированияя открывается, а портал - нет пишет пробный период истек. Пытаюсь вводить свою лицензию ничего не меняется.
В журналах приложений ошибки com объектов
Вопрос закрыт. После неких танцев с бубном портал заработал.

Страницы: 1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465

Предыдущая тема: Безопасность локальной сети с роутером


Форум Ru-Board.club — поднят 15-09-2016 числа. Цель - сохранить наследие старого Ru-Board, истории становления российского интернета. Сделано для людей.